import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^$\\r\\n]*\\$[^$\\r\\n]*){2}$";
final String string = "Home$Fruits\n"
+ "Home$Fruits$Apple\n"
+ "Home$Fruits$Apple$Red-Apple\n"
+ "Home$Fruits$Apple$Green-Apple\n"
+ "Home$Fruits$Banana$Yellow-Banana\n"
+ "Home$Fruits$Banana$Green-Banana\n"
+ "Home$Fruits$Orange\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}