import Foundation
let pattern = #"^(?:[^$\r\n]*\$[^$\r\n]*){2}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Home$Fruits
Home$Fruits$Apple
Home$Fruits$Apple$Red-Apple
Home$Fruits$Apple$Green-Apple
Home$Fruits$Banana$Yellow-Banana
Home$Fruits$Banana$Green-Banana
Home$Fruits$Orange
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)