const regex = /^(\w+)\s+(\d+\/\d+),\s+\w+:\s*(\d+(?:\.\d+){1,2})\s*(.*?)\s*([a-zA-Z]+\s*\d{1,2},\s*\d{4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w+)\\s+(\\d+\\\/\\d+),\\s+\\w+:\\s*(\\d+(?:\\.\\d+){1,2})\\s*(.*?)\\s*([a-zA-Z]+\\s*\\d{1,2},\\s*\\d{4})$', 'gm')
const str = `Username 5/5, Version: 1.0 This is a custom message Sep 25, 2018`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}