re = /^(\w+)\s+(\d+\/\d+),\s+\w+:\s*(\d+(?:\.\d+){1,2})\s*(.*?)\s*([a-zA-Z]+\s*\d{1,2},\s*\d{4})$/m
str = 'Username 5/5, Version: 1.0 This is a custom message Sep 25, 2018'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end