import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z]{1,5}[9]{0,4}[0-9]{6}[A-Z]{1,2}[9]{0,1}[0-9][A-Z0-9]{2}";
final String string = "my driving lincence number is MORGA753116SM9IJ and JONES849339TS8AD\n"
+ "and MORGA753116SM9IJ123abc\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}