re = /[A-Z]{1,5}[9]{0,4}[0-9]{6}[A-Z]{1,2}[9]{0,1}[0-9][A-Z0-9]{2}/m
str = 'my driving lincence number is MORGA753116SM9IJ and JONES849339TS8AD
and MORGA753116SM9IJ123abc
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end