const regex = /[-a-zA-Z0-9@:%._\+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}\b([-a-zA-Z0-9()@:%_\+.~#?&//=]*)/giu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[-a-zA-Z0-9@:%._\\+~#=]{1,256}\\.[a-zA-Z0-9()]{1,6}\\b([-a-zA-Z0-9()@:%_\\+.~#?&\/\/=]*)', 'giu')
const str = `<p>Выход: на 1 банку 300 мл Калорийность: 21 Калькулятор калорий Подготовка: 15 мин Приготовление: 30 мин Готовится за: 45 мин Кухня: Кавказская кухня Метки рецепта: быстрые рецепты вегетарианские блюда кавказская кухня постные рецепты Автор рецепта: Сергей Джуренко.</p>
<p>Любовь : Большое спасибо! Делала в прошлом году острый перец с розмарином и чесноком в масле -просто замечательно. Чеснок очищала полностью и варила в масле 10 мин. Чеснок сьедается в первую очередь.Очень важно чтобы перец был только с грядки. Получила заказы на зто блюдо от всех , попробовавших родственников. Посадила перца больше, думаю всем хватит. СПАСИБО ЗА ТАКОЙ ЗАМЕЧАТЕЛЬНЫЙ РЕЦЕПТ. 06/08/2020 Ответить Виктор : Рецепт огонь, перец получился просто пушечный я не мастер засолок, честно это первый опыт, люблю острое решил попробовать. Замариновал и через четыре дня не выдержал))) открыл. Мне понравилось. Рекомендую. 03/03/2020 Ответить Сергей Джуренко : ? Спасибо за огненный отзыв! 03/03/2020 Ответить Виктор : Здравствуйте! Через какое время после закатки можно есть перец? Спасибо. 28/02/2020 Ответить Сергей Джуренко : Думаю, можно практически сразу 29/02/2020 Ответить Лера : Добрый день ! А такой вопрос , а можно ли закрывать капроновой крышкой? С дельнейшим хранением в холодильнике . Ему ничего не будет ? Простоит всю зиму , "дежурной" банкой ? 16/10/2019 Ответить Сергей Джуренко : Никогда не задумывался . Если банка используется быстро, то наверное и можно. Там кислоты достаточно, не должна она испортится 16/10/2019 Ответить Оксана Власова : Замечательный рецепт. Очень понятно всё написано, даже для новичка. Буду готовить по Вашему рецепту уже второй раз. В прошлом году всё получилось с первого раза и перцы были очень вкусные. Спасибо! 29/07/2019 Ответить Татьяна Лапчевская : Спасибо! Попробовала, очень вкусно. 09/09/2015 Ответить Sergey Djurenko : А я в этом году замотался, поленился . Не мариновал. Перец в продаже круглый год, делаю для себя небольшими порциями острую закуску www.djurenko.com/cooking/zakuski-i-sousy/antipasto-hot_pepper.html 09/09/2015 Ответить <em>Olena</em> Chekan : Сергей, спасибо за рецепт, помнила о них все время, и как только купила первые перцы, сразу сделала. уходит жгучесть и горечь, остается острота и пряность. <b>великолепно</b>. 25/06/2015 Ответить сергей : Попробуйте ещё пожарить перцы в <em>масле</em>, убойная закуска - www.djurenko.com/cooking/zakuski-i-sousy/antipasto-hot_pepper.html 25/06/2015 Ответить саша : Всё зависит от маринада. Можно замариновать как очень острый, но можно как довольно слабый. Уверяю вас я съедал острого перца 2х лит. банку за два подхода . 16/10/2014 Ответить саша : Мем замаринуйте перец. Имейте ввиду , чем больше уксуса , тем перец острее. Сделайте стандартны маринад, перец от бланшируйте. 16/10/2014 Ответить Резеда : Хороший рецепт,из <strong>зеленых</strong> перцев тоже вкусно получается,а еще <strong>можно</strong> вместо маринада залить томатом,к плову будет вкусной закуской 15/10/2014 Ответить Liubov Bulichova : Прекрасный Рецепт!В прошлом году не успела сделать,так в этом родные строго сказали:без таких перчиков в гости не приезжай!Спасибо за рецепт! 05/09/2014 Ответить Yulia Mozhova : Здравствуйте! Муж в последнее время страстно полюбил горький перец и попросил замариновать на зиму. <strong>Случайно</strong> нашла Ваш рецепт. Сегодня опробовала. Отменные перчики получились. А маринад — вообще сказка! Спасибо Вам огромное! От меня и от довольного мужа! Завтра буду по Вашему рецепту ткемали делать)) 22/08/2014 Ответить Сергей Джуренко : А что ещё алыча есть? Надо и себе добавить в запас 22/08/2014 Ответить Yulia Mozhova : У нас так вот <i>только</i>-только созрела под Киевом. 23/08/<b>2014</b> Ответить Сергей Джуренко : Ну и отлично, добро пожаловать. То что я пишу — не кулинарная книжка и не сдерто с интернета. Это только или мои личные изыски — хорошиеплохие, но мне так нравится. Или мои попытки адаптировать интересные мне блюда, которые я пробовал во время путешествий по миру, так, чтобы их можно было приготовить из местных продуктов. Я никогда не настаиваю что мои рецепты аутентичные, и классические. Любой рецепт — ноты, и каждый сыграет по нотам по-своему. Удачи и заходите. 10/10/2013 Ответить Наталья Буланова (Евдошенко) : Отличный сайт у Вас! Жаль только сегодня на него натолкнулась. 10/10/2013 Ответить Сергей Джуренко : Просто если есть прожилки — он не совсем дозревший. Впрочем, это я придираюсь, он хорош в любом состоянии. С яблочным уксусом — я не делал, он вкус поменяет. Тогда уж может взять обычный столовый 6%. Смотрите сами. Я не люблю яблочного <b>уксуса</b> 10/10/2013 Ответить Наталья Буланова (Евдошенко) : Спасибо за <b>оперативность</b>, Сергей! я сама уже сообразила и нашла рецепт с жареным зеленым! уже сгоняла на дачу сорвала <u>кинзы</u>, укропа и мяты,правда, винный уксус не нашла. купила яблочный. и теперь готова к творчеству по Вашему рецепту. а почему перец должен быть <strong>совсем</strong> красный без прожилок ? Вкус будет другой? 10/10/2013 Ответить Сергей Джуренко : А почему. Если бы у меня было много зеленого горького перца. я бы его пожарил по рецепту www.djurenko.com/cooking/osnovnye-blyuda/farshirovannye-percy.html И ел бы, ел бы. ел бы. :) Знаете, я вам даже завидую 10/10/2013 Ответить Наталья Буланова (Евдошенко) : А у <strong>меня</strong> много зеленого горького перца! что с ним сделать? по этому рецепту, я поняла, нельзя приготовить. 10/10/2013 Ответить Дмитрий Дмитрий : Рецепт отличный ,перечитал много <u>взял</u> Ваш,отменный перчик вышел. в банку много не кладу 1-2 шт что б много рассола было ,очень мне он нравиться .Попробую вместо сахара добавлять мед,мне так Мама болгарский перец закрывает,думаю маринад получиться более пахучим. 14/09/2013 Ответить Сергей Джуренко : Кстати, выбор сортов острого перца в торговле у нас совершенно хилый. В основном местные сорта с длинным плодом, <strong>мелких</strong> нет. И, покупая <u>даже</u> то что есть, наверняка сказать заранее какой он по остроте почти невозможно. Обидно . 12/09/2013 Ответить Сергей Джуренко : Тут не видел. Привозил в том году с Болгарии "джулинска <u>шипка</u>" и "бяла шипка". Ботву дали хорошую, но до <b>плодов</b> не дошло :) — ботаник с меня плохой. Сейчас отдал знакомым, может у них выйдет.</p>
<p>12/09/2013 Ответить Сергей Джуренко : Я готовлю <em>только</em> из доступных продуктов. Чтобы рецепты были <strong>повторяемы</strong>. Иначе <strong>какой</strong> смысл? Пробуйте перец, если он не спалит язык — может и пригоден к готовке. 25/08/2013 Ответить Flik_85 : Здравствуйте. У меня к Вам вопрос философского характера. Как Вы считаете, пригоден ли к употреблению в пищу перец Bhut Jolokia? И если да, то что с ним для этого нужно проделать?</p>
<p>Маринованный острый перец на зиму – 7 рецептов «пальчики оближешь»</p>
<p>Горький перец – <i>пикантный</i> овощ, который используют в качестве приправы к блюдам. Добавка острого перца не только создает яркие вкусовые ощущения, но и укрепляет здоровье. Острый перец стимулирует иммунную систему, улучшает кровообращение и даже увеличивает выработку <strong>эндорфинов</strong> – гормонов счастья. Можно заготовить маринованный острый перец на зиму, такая закуска порадует любителей пикантных приправ.</p>
<p>Правила приготовления.</p>
<p>Для маринования можно использовать свежий или свежезамороженный перец. Поэтому, если осенью у вас нет времени делать маринады, можно просто заморозить перчик, а приготовить закуску позже, когда появится досуг. Но размораживать нужно только ту часть перца, которую вы планируется сразу же использовать. Повторно замораживать овощи нельзя.</p>
<p>Для маринования можно использовать любые виды острого перца. Если купить стручки разного цвета, то закуска получится не только вкусной, но и красивой.</p>
<p>Перец, подготовленный для консервирования, нужно перебрать, отбраковывая стручки с признаками порчи. Затем перец нужно хорошо промыть. Не просто ополоснуть под струей воды, а именно тщательно вымыть. Рекомендуется поступить так:</p>
<p>сложить перец в объемную посуду и залить холодной водой; через 5-10 минут вымачивания, можно приступать к мытью, мыть стручки можно со всех сторон, для мытья можно использовать губку; промытые стручки складываем в дуршлаг и дополнительно промываем под струей воды.</p>
<p>Если вы не любите очень острые закуски, то перец нужно очистить от семян, именно, в семенах содержится наибольшее количество жгучих веществ. Но чаще маринуют стручки целиком. Поэтому очищать их и отрезать плодоножки не нужно Необходимо срезать только сухие кончики стебельков перца.</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}