$re = '/(mother|father)(.*?)(?!\1)(?1)/m';
$str = 'Postive matches:
mother a father
father a mother
father a mother a father
mother a father a mother
something else mother a father a father mother blablö mother and father
not this mother mother or
or father father but this
Non-matches:
just mother
just father
mother then mother
father then father
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);