# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(mother|father)(.*?)(?!\1)(?1)"
test_str = ("Postive matches:\n"
"mother a father\n"
"father a mother\n"
"father a mother a father\n"
"mother a father a mother\n\n"
"something else mother a father a father mother blablö mother and father \n\n"
"not this mother mother or\n"
"or father father but this\n\n"
"Non-matches:\n"
"just mother\n"
"just father\n"
"mother then mother\n"
"father then father\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.