#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[0-9]+\n|\n)(([0-9:,]+)([\s->]+)([0-9:,]+))$"
Local $sString = "1" & @CRLF & _
"00:00:04,019 --> 00:00:07,299" & @CRLF & _
"- cdcdc" & @CRLF & _
"- cddcd" & @CRLF & _
"" & @CRLF & _
"2" & @CRLF & _
"00:00:07,414 --> 00:00:09,155" & @CRLF & _
"54564" & @CRLF & _
"" & @CRLF & _
"00:00:09,276 --> 00:00:11,429" & @CRLF & _
"- 445454 - ccd" & @CRLF & _
"- cdscdcdcd" & @CRLF & _
"" & @CRLF & _
"00:00:11,549 --> 00:00:14,874" & @CRLF & _
"line1" & @CRLF & _
"line2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")