import re
regex = re.compile(r"^(?:[0-9]+\n|\n)(([0-9:,]+)([\s->]+)([0-9:,]+))$", flags=re.MULTILINE)
test_str = ("1\n"
"00:00:04,019 --> 00:00:07,299\n"
"- cdcdc\n"
"- cddcd\n\n"
"2\n"
"00:00:07,414 --> 00:00:09,155\n"
"54564\n\n"
"00:00:09,276 --> 00:00:11,429\n"
"- 445454 - ccd\n"
"- cdscdcdcd\n\n"
"00:00:11,549 --> 00:00:14,874\n"
"line1\n"
"line2\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")