re = /^~~(\d+)~~$/m
str = '~~333~~
~~this is ~~~~~ a test ~~ test~~
~~~333~~~
~~~~333~~~~
~~~this is ~ a test ~~ test~~
~~this is ~ a test ~~~~
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end