// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^~~(\d+)~~$").unwrap();
let string = "~~333~~
~~this is ~~~~~ a test ~~ test~~
~~~333~~~
~~~~333~~~~
~~~this is ~ a test ~~ test~~
~~this is ~ a test ~~~~
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}