import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bCourt\\h+(?:Case\\h+Fee|Filing Fee:)\\h+(?:Contract\\h+)?\\$\\K\\d+\\.\\d+";
final String string = "Court Case Fee $214.00 Payment Service Fee $6.91 E-File Fee $25.00\n"
+ "Court Filing Fee: Contract $198.00eFiling Fee $30.00Convenience Fee $8.28Total $236.28";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}