const regex = /\bCourt\h+(?:Case\h+Fee|Filing Fee:)\h+(?:Contract\h+)?\$\K\d+\.\d+/mig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bCourt\\h+(?:Case\\h+Fee|Filing Fee:)\\h+(?:Contract\\h+)?\\$\\K\\d+\\.\\d+', 'mig')
const str = `Court Case Fee \$214.00 Payment Service Fee \$6.91 E-File Fee \$25.00
Court Filing Fee: Contract \$198.00eFiling Fee \$30.00Convenience Fee \$8.28Total \$236.28`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}