package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:56|78)-[0-9]+|[0-9]{2,})$`)
var str = `Valid matches:
minimun two characters and only numbers OR
only numbers with dash in third position and first two numbers should be either 56 or 78. So if there is dash then there should be 56 or 78 next to it
12
123456789
423432423423423423423432
56-1
56-23456789
78-12
78-34234234234234234234234
Invalid matches:
1
1-
11-
1-112
44-2342424
64-4345334
55-sdrfewrwe
56-
5678-234324123423154`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}