// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:56|78)-[0-9]+|[0-9]{2,})$").unwrap();
let string = "Valid matches:
minimun two characters and only numbers OR
only numbers with dash in third position and first two numbers should be either 56 or 78. So if there is dash then there should be 56 or 78 next to it
12
123456789
423432423423423423423432
56-1
56-23456789
78-12
78-34234234234234234234234
Invalid matches:
1
1-
11-
1-112
44-2342424
64-4345334
55-sdrfewrwe
56-
5678-234324123423154";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}