const regex = new RegExp('^(.*?)(\\d+p) *(.+)', 'gm')
const str = `300p apple in house
orange 200p in school
`;
const subst = `\1\3 \2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);