import re
regex = re.compile(r"^(.*?)(\d+p) *(.+)", flags=re.MULTILINE)
test_str = ("300p apple in house\n"
"orange 200p in school\n")
subst = "\\1\\3 \\2"
result = regex.sub(subst, test_str)
if result:
print(result)