$re = '/(?:^.*?\[|\G)[ \w+]*\K\[[ \w+]*\](?=[ \w+]*(?:\[[ \w+]*\][ \w+]*)*\])/m';
$str = 'Say [hello] or [[hello] hello [world] ] [world] [word] now
Say [hello] or [[hello] hello ] [world] ] [world] [word] n';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);