re = /(?:^.*?\[|\G)[ \w+]*\K\[[ \w+]*\](?=[ \w+]*(?:\[[ \w+]*\][ \w+]*)*\])/m
str = 'Say [hello] or [[hello] hello [world] ] [world] [word] now
Say [hello] or [[hello] hello ] [world] ] [world] [word] n'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end