#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)미소"
Local $sString = "더 캄캄한 이곳에 shine like the stars" & @CRLF & _
"그 미소를 띠며 I'll kiss you goodbye" & @CRLF & _
"" & @CRLF & _
"실컷 비웃어라 꼴좋으니까" & @CRLF & _
"이제 너희 1 2 3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")