package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\w\s\?]+`)
var str = ` привет, Вася
как дела?
уиии!!
давай Вася, до свидания!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}