$re = '/[^\w\s\?]+/u';
$str = ' привет, Вася
как дела?
уиии!!
давай Вася, до свидания!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);