package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^AT[1-5]G[0-9]{1,5}$`)
var str = `AT1G01040`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}