$re = '/^AT[1-5]G[0-9]{1,5}$/';
$str = 'AT1G01040';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);