package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\[\[([^][]*)SPACE([^][]*)]]`)
var str = `..text.. [[wordoneSPACE**wordtwo**]] ..moretext..
.. [[ ..text(not to cut).. [[wordoneSPACE**wordtwo**]] ..moretext..`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}