re = /\[\[([^][]*)SPACE([^][]*)]]/i
str = '..text.. [[wordoneSPACE**wordtwo**]] ..moretext..
.. [[ ..text(not to cut).. [[wordoneSPACE**wordtwo**]] ..moretext..'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end