package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)http:\/\/GNTXN.US\/\S+`)
var str = `Test Message: We want to hear from you! Take our 2022 survey & tell us what matters most to you this year: http://GNTXN.US/qsx Text STOP 2 stop/HELP 4 help`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}