re = /http:\/\/GNTXN.US\/\S+/m
str = 'Test Message: We want to hear from you! Take our 2022 survey & tell us what matters most to you this year: http://GNTXN.US/qsx Text STOP 2 stop/HELP 4 help'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end