$re = '/<p( class=\"[^\"]+\")??( style=\"[^\"]+\")??.+<img[^>]+><.p>/m';
$str = '<p class=\\"DailyReadingImage\\" field=\\"heading\\"><img src=\\"../Final/Images/$1.$2 Spanish.png\\" style=\\"real-height: 0.25in; real-width: 0.25in; width: 50%\\" /></p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);