// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<p( class=\"[^\"]+\")??( style=\"[^\"]+\")??.+<img[^>]+><.p>"#).unwrap();
let string = "<p class=\\\"DailyReadingImage\\\" field=\\\"heading\\\"><img src=\\\"../Final/Images/$1.$2 Spanish.png\\\" style=\\\"real-height: 0.25in; real-width: 0.25in; width: 50%\\\" /></p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}