using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:25(?:25|10|5)|10(?:25|10(?:5(?:25|5|10)|25|10)|5(?:25|10(?:25|10|5)|5(?:5(?:25|5|10)|25|10)))|5(?:25|10(?:25|10(?:25|10|5)|5(?:5(?:25|5|10)|25|10))|5(?:25|10(?:5(?:25|5|10)|25|10)|5(?:25|10(?:25|10|5)|5(?:5(?:25|5|10)|25|10)))))(?:25|10|5)*$";
string input = @"55555555555";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}