const regex = /^(?:25(?:25|10|5)|10(?:25|10(?:5(?:25|5|10)|25|10)|5(?:25|10(?:25|10|5)|5(?:5(?:25|5|10)|25|10)))|5(?:25|10(?:25|10(?:25|10|5)|5(?:5(?:25|5|10)|25|10))|5(?:25|10(?:5(?:25|5|10)|25|10)|5(?:25|10(?:25|10|5)|5(?:5(?:25|5|10)|25|10)))))(?:25|10|5)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:25(?:25|10|5)|10(?:25|10(?:5(?:25|5|10)|25|10)|5(?:25|10(?:25|10|5)|5(?:5(?:25|5|10)|25|10)))|5(?:25|10(?:25|10(?:25|10|5)|5(?:5(?:25|5|10)|25|10))|5(?:25|10(?:5(?:25|5|10)|25|10)|5(?:25|10(?:25|10|5)|5(?:5(?:25|5|10)|25|10)))))(?:25|10|5)*$', 'gm')
const str = `55555555555`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}