# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/NN\.[^.]*\.//gm;t' <<< "['NN.KTXS/KTXE.FOO BAR.STACK.OVERFLOW', 'NN.WFXL.Harlan KY.Harlan.KY', 'NN.WRGB/WCWN.Los Angeles CA.Burbank.CA', 'NN.KVII/KVIH.Denver.Denver.CO', 'NN.KEYE.Denver.Denver.CO']"