re = /NN\.[^.]*\./m
str = '[\'NN.KTXS/KTXE.FOO BAR.STACK.OVERFLOW\', \'NN.WFXL.Harlan KY.Harlan.KY\', \'NN.WRGB/WCWN.Los Angeles CA.Burbank.CA\', \'NN.KVII/KVIH.Denver.Denver.CO\', \'NN.KEYE.Denver.Denver.CO\']'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result