import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:1,[89]|(?:[2-9]|[1-9]\\d{1,2}),\\d)\\d\\d,\\d{3} K";
final String string = "1,455,204 K\n"
+ "1,800,000 K\n"
+ "2,000,000 K\n"
+ "15,000,000 K";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}