$re = '/\b(?:1,[89]|(?:[2-9]|[1-9]\d{1,2}),\d)\d\d,\d{3} K/m';
$str = '1,455,204 K
1,800,000 K
2,000,000 K
15,000,000 K';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);