re = /(?<return>return)|(?<other>(?:(?!return)\S)+)/m
str = 'return abc 123
;return this'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end