use strict;
my $str = 'Examples that work
[COI vol 5] Post title
Post title (coi ch 890+)
Post title (coi general)
Post [Lotm something] title
Examples that don\'t work
[coi] with no vol/ch specification or the "general" keyword
[idk lotm] lotm/coi must be at the start
(Coi ch 8 cool) " cool" should be outside the brackets
Lotm Tests
[Lotm] Title here
[LOM] Title here
[Lotm ] Title here
[LOM Vol 3] Lotm works with anything after it
[Lom vol 3] Lotm works with anything after it
[lotm random] stuff
(lotm not closed fails
COI tests
[COI] fails
[COI vol 3] Title here
[COI ch850+] Title here
[COI 231] Assumed this is the chapter #
[coi352] a lazy person
[COIvol3] Spacing Optional
[COIch.3] Spacing Optional
[coi231] lower case is fine
[COIch293] hopefully no one does this in practice lol
[COI vol 5 ch 894] should work
[coi vol5 ch23]
[coivol2ch.43]
[coi chs 253-455] chapter range
(coi vol 3&5) & character added
[coi chs 231]
[COI random] fails
Anime/donghua tests (unadvertised)
(donghua ep1) just added this, unadvertised though
(anime trailer) unadvertised';
my $regex = qr/(?i:(\[|\()(((donghua|anime).*)|((LOM|LotM|COI)( ?)(Vol|(Volume)?)( ?)([0-9\-&]*)( ?)(Chapter|Chap|(Ch)?)(.?)( ?)([0-9\-&]+|general|end)(\+?)([ \/]?privilege)?))(]|\)))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}