import re
regex = re.compile(r"(?i:(\[|\()(((donghua|anime).*)|((LOM|LotM|COI)( ?)(Vol|(Volume)?)( ?)([0-9\-&]*)( ?)(Chapter|Chap|(Ch)?)(.?)( ?)([0-9\-&]+|general|end)(\+?)([ \/]?privilege)?))(]|\)))", flags=re.MULTILINE)
test_str = ("Examples that work\n"
"[COI vol 5] Post title\n"
"Post title (coi ch 890+)\n"
"Post title (coi general)\n"
"Post [Lotm something] title\n\n"
"Examples that don't work\n"
"[coi] with no vol/ch specification or the \"general\" keyword\n"
"[idk lotm] lotm/coi must be at the start\n"
"(Coi ch 8 cool) \" cool\" should be outside the brackets\n\n"
"Lotm Tests\n"
"[Lotm] Title here\n"
"[LOM] Title here\n"
"[Lotm ] Title here\n"
"[LOM Vol 3] Lotm works with anything after it\n"
"[Lom vol 3] Lotm works with anything after it\n"
"[lotm random] stuff\n"
"(lotm not closed fails\n\n"
"COI tests\n"
"[COI] fails\n"
"[COI vol 3] Title here\n"
"[COI ch850+] Title here\n"
"[COI 231] Assumed this is the chapter #\n"
"[coi352] a lazy person\n"
"[COIvol3] Spacing Optional\n"
"[COIch.3] Spacing Optional\n"
"[coi231] lower case is fine\n"
"[COIch293] hopefully no one does this in practice lol\n"
"[COI vol 5 ch 894] should work\n"
"[coi vol5 ch23]\n"
"[coivol2ch.43] \n"
"[coi chs 253-455] chapter range\n"
"(coi vol 3&5) & character added\n"
"[coi chs 231] \n"
"[COI random] fails\n\n"
"Anime/donghua tests (unadvertised)\n"
"(donghua ep1) just added this, unadvertised though\n"
"(anime trailer) unadvertised")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")