const regex = /["'`](?:(?<=")[^"\\]*(?s:\\.[^"\\]*)*"|(?<=')[^'\\]*(?s:\\.[^'\\]*)*'|[^`]*`)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('["\'`](?:(?<=")[^"\\\\]*(?s:\\\\.[^"\\\\]*)*"|(?<=\')[^\'\\\\]*(?s:\\\\.[^\'\\\\]*)*\'|[^`]*`)', 'g')
const str = `Almost every SQL statement uses \`identifier\`s in some way to refer to a database or its constituent elements such as tables, views, columns, indexes, stored routines, triggers, or events. When you refer to elements of databases, \`identifier\`s must conform to the following rules.
Legal characters in \`identifier\`s. Unquoted \`identifier\`s may consist of latin letters a-z in any lettercase, digits 0-9, dollar, underscore, and Unicode extended characters in the range U+0080 to U+FFFF. \`Identifier\`s can start with any character that is legal in an \`identifier\`, including a digit. However, an unquoted \`identifier\` cannot consist entirely of digits because that would make it indistinguishable from a number. MySQL’s support for \`identifier\`s that begin with a number is somewhat unusual among database systems. If you use such an identifier, take particular care if it contains an 'E' or 'e' because those characters can lead to ambiguous expressions. For example, the expression 23e + 14 (with spaces surrounding the '+' sign) means column 23e plus the number 14, but what about 23e+14? Does it mean the same thing, or is it a number in scientific notation?
\`Identifier\`s can be "quoted" (delimited) within backtick characters ('\`'), which permits use of any character except a NUL byte or Unicode supplementary characters (U+10000 and up):
"string \\"string\\" string"
"string \\\\"string\\\\" string"
'string \\'string\\' string'
'string \\\\'string\\\\' string'
\`string string\`
\`string \`string\` string\``;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}