use strict;
my $str = 'Almost every SQL statement uses `identifier`s in some way to refer to a database or its constituent elements such as tables, views, columns, indexes, stored routines, triggers, or events. When you refer to elements of databases, `identifier`s must conform to the following rules.
Legal characters in `identifier`s. Unquoted `identifier`s may consist of latin letters a-z in any lettercase, digits 0-9, dollar, underscore, and Unicode extended characters in the range U+0080 to U+FFFF. `Identifier`s can start with any character that is legal in an `identifier`, including a digit. However, an unquoted `identifier` cannot consist entirely of digits because that would make it indistinguishable from a number. MySQL’s support for `identifier`s that begin with a number is somewhat unusual among database systems. If you use such an identifier, take particular care if it contains an \'E\' or \'e\' because those characters can lead to ambiguous expressions. For example, the expression 23e + 14 (with spaces surrounding the \'+\' sign) means column 23e plus the number 14, but what about 23e+14? Does it mean the same thing, or is it a number in scientific notation?
`Identifier`s can be "quoted" (delimited) within backtick characters (\'`\'), which permits use of any character except a NUL byte or Unicode supplementary characters (U+10000 and up):
"string \\"string\\" string"
"string \\\\"string\\\\" string"
\'string \\\'string\\\' string\'
\'string \\\\\'string\\\\\' string\'
`string string`
`string `string` string`';
my $regex = qr/["'`](?:(?<=")[^"\\]*(?s:\\.[^"\\]*)*"|(?<=')[^'\\]*(?s:\\.[^'\\]*)*'|[^`]*`)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}