const regex = /(cookiebot|2gdpr)\.com/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(cookiebot|2gdpr)\\.com', 'ig')
const str = `Cookiebot:
Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko; compatible; Cookiebot/1.0; +http://cookiebot.com/) Chrome/101.0.4951.54 Safari/537.36
2GDPR:
Mozilla/5.0 (compatible; 2GDPR/1.2; https://2gdpr.com)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}