$re = '/(cookiebot|2gdpr)\.com/i';
$str = 'Cookiebot:
Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko; compatible; Cookiebot/1.0; +http://cookiebot.com/) Chrome/101.0.4951.54 Safari/537.36
2GDPR:
Mozilla/5.0 (compatible; 2GDPR/1.2; https://2gdpr.com)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);