using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^STARTING LINE .+\n(?!(?:(?!(?:STARTING|ENDING) LINE ).+\n)*ENDING LINE )";
string input = @"...
STARTING LINE with something 83
...
STARTING LINE with other 12
...
ENDING LINE with yet another info
...
STARTING LINE with another 43
...";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}