$re = '/^STARTING LINE .+\n(?!(?:(?!(?:STARTING|ENDING) LINE ).+\n)*ENDING LINE )/m';
$str = '...
STARTING LINE with something 83
...
STARTING LINE with other 12
...
ENDING LINE with yet another info
...
STARTING LINE with another 43
...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);