import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\w.]+:[^|]+\\|[^|]+(?:\\|#(?:[\\w.]+:[^,\\n]+(?:,|$))*)?$";
final String string = "performance.os.disk:1099511627776|g|#region:us-west-1,datacenter:us-west-1a\n"
+ "performance.os.disk:1099511627776|g|#\n"
+ "performance.os.disk:1099511627776|g|#region:us-west-1\n"
+ "datastore.reads:9876|ms";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}