// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\w.]+:[^|]+\|[^|]+(?:\|#(?:[\w.]+:[^,\n]+(?:,|$))*)?$").unwrap();
let string = "performance.os.disk:1099511627776|g|#region:us-west-1,datacenter:us-west-1a
performance.os.disk:1099511627776|g|#
performance.os.disk:1099511627776|g|#region:us-west-1
datastore.reads:9876|ms";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}