import re
regex = re.compile(r"^(?!_)(?!.*_$)[a-zA-Z0-9_]+$", flags=re.MULTILINE)
test_str = ("Valid Entries: \n"
"abc\n"
"ABC\n"
"Abc123\n"
"123a\n"
"Abc_12\n"
"Abc_12_3a\n"
"abc_23_43_fg\n\n"
"Invalid Entries: \n"
"_abc\n"
"abc_\n"
"_abc_")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")